CVE-2021-45105 Log4Shell

What is CVE-2021-45105 (Log4Shell)?

In summary,

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0 and 2.12.3.

National Vulnerability Database

Is Cascade CMS affected by CVE-2021-45105 (Log4Shell)?

As was the case for CVE-2021-44228, CVE-2021-45105 does not impact Cascade Cloud or on-premise distributions of Cascade CMS because message lookup substitution is not supported in our use of log4j.