Skip to main content

Cascade CMS 8.11.1

End of Life

Cascade CMS version 8.11.1 is a patch release containing a number of improvements and fixes to WCAG accessibility content checks (Cascade Cloud), WYSIWYG Editor Configurations, Shared Fields, and site imports among others.

2 Improvements 15 Fixes

Release Notes

Improvements

  • Users who receive scheduled publish reports will now be notified in the report if a scheduled publish fails because a site has no enabled Destinations.
  • Users publishing one or more selected assets from a list will now receive a warning if they have no enabled Destinations available to them.

Fixed

  • WYSIWYG editor fields using deprecated options in a Data Definition now load properly without Javascript errors.
  • Addressed an issue where the New Content dashboard widget would not properly load if the configured Site's base Asset Factory Container contained a sub-container.
  • Submitting content checks during the edit process will no longer prompt the user about unsaved changes.
  • Updating the SMTP password and Widen Collective API key system preferences via Web Services will now encrypt the values instead of persisting them as plain text.
  • Viewing a previewable file (e.g. PDF) will no longer result in two consecutive render requests.
  • Re-enabled the paragraph option within the WYSIWYG's Formats menu.
  • It's no longer possible to assign a recycled Template to a Configuration.
  • If a Template that's in use is recycled, an error will be output to the logs with the associated Configurations to update.
  • Addressed an issue during site imports where empty files would fail to be created.
  • Addressed an issue during site imports where Content Types with associated Publish Sets would fail to be created.
  • Viewing a Shared Field with a &type= parameter in the URL will not longer throw a NullPointerException.
  •   WCAG accessibility content checks for WYSIWYGs now happen asynchronously as opposed to one field at a time, improving overall check speed.
  •   WCAG tests applicable to full pages only have been omitted from the accessibility content checks for WYSIWYGs to help prevent false positives.
  •   Sites with an Accessibility Report associated with them can now be deleted.
  •   Addressed an issue where an Accessibility Report will not complete if an error is encountered while it is running.

Upgrade Guide

First time installation?

Be sure to import our default database schema prior to installing Cascade CMS for the first time. Then follow the appropriate installation instructions for your environment.

Upgrade Steps

  1. Shut down your currently running Cascade CMS environment.
  2. Before you upgrade, we strongly recommend that you back-up your production database as well as set up a test environment and perform a trial run of the upgrade. All customers are entitled to a test license for this purpose.
  3. Read the release notes and upgrade guides for all releases between your version and the latest version.
  4. Check the table below to see which installer type is required.

Which installer should I use?

With certain upgrade paths, a full installation of Cascade CMS is required in order to ensure that the application has the latest required libraries. See the table below for a summary of which installer you should use based on the version from which you are upgrading. For any versions that do not require a full installation, using the ROOT.war upgrade method is allowed.

Upgrade Path
Upgrading From Full Installation Required
7.x Yes
8.0.x Yes
8.1.x Yes
8.2.x Yes
8.3 Yes
8.4.x Yes
8.5 Yes
8.6.x Yes
8.7.x Yes
8.8.x Yes
8.9 Yes
8.9.1 Yes
8.10 Yes
8.11 No

Requirements & Supported Platforms

Server Requirements (for CMS deployment)

Application server requirements (for the CMS)
  Requirement Notes
CPU
  • 8-core (recommended)
  • Quad core (minimum)
  • Cascade can be run in virtualized environments like VMware and Hyper-V
Memory
  • 8GB RAM (recommended)
  • 6GB RAM (minimum)
  • It is recommended to allocate approximately 1/2 of the server’s total memory to Cascade.
Hard Drive Space
  • 20GB (recommended)
  • 10GB (minimum)
 

Supported Platforms

Supported platforms
  Supported platform(s) Supported version(s) Notes
Java platforms Oracle Server JRE or JDK
  • Java 8u191 or higher
  • Server JRE is recommended for Windows and Linux
  • 64-bit is recommended for all platforms
  • Other Java distributions including OpenJDK are not supported
Operating System Microsoft Windows Server
  • 2016
  • 2012 / 2012 R2
 
Mac OS X Server
  • 10.4 or later
 
Linux
  • 64-bit (recommended)
  • 32-bit
 
Databases MySQL
  • 5.7
  • 5.6
  • 5.5
 
Microsoft SQL Server
  • 2016
  • 2014
  • 2012
 
Oracle
  • 12c
  • 11g
 
Web servers Apache    
Microsoft IIS    
Sun Java System Web Server  
  • Formerly Netscape Enterprise Server
Zeus Web Server    
Web browsers Chrome
  • Chrome 50+
 
Microsoft
  • Edge
  • Internet Explorer 11
 
Mozilla Firefox
  • Firefox 45+


Safari
  • Safari 8+