Cascade CMS 8.13.1

Cascade CMS 8.13.1 is a patch release containing fixes for regressions introduced in Cascade CMS 8.13, improved user notification count load times, fixes to PDF file rendering in IE11 among other improvements and fixes.

  View Requirements

Features/Improvements

  • We've improved load times for screens such as the Dashboard that rely on counting a user's notifications.

Issues Fixed

  • To prevent issues with parts of the interface being hidden when viewing PDFs in Internet Explorer 11 (IE11), users will be prompted to preview the PDF in a separate tab instead.
  • Assets using Data Definitions and Shared Fields outside of the current site will no longer lose Shared Field content when edited with Web Services.
  • We've addressed an issue where, under certain circumstances, Asset Factories would not place assets within their designated placement folder.
  • Oracle clients running 12.2+ will no longer experience database update errors relating to adding constraints to Custom Workflow Email tables during the upgrade process from prior to Cascade CMS 8.13.
  • Oracle clients running 12.2+ metadata values now use the correct data type.
  • We've addressed an issue where sites exported prior to Cascade CMS 8.13 do not import into Cascade CMS 8.13 with a Custom Workflow Email container.
  • The Windows installer has been updated to address an SSL connection error after upgrading to Cascade CMS 8.13.
  • Workflow comments will no longer be repeated for system steps in a Workflow Definition.

First time installation?

Be sure to import our default database schema prior to installing Cascade CMS for the first time. Then follow our standard installation instructions.

Upgrade Steps

  1. Shut down your currently running Cascade CMS instance.
  2. Before you upgrade, we strongly recommend that you back-up your production database. as well as set up a test instance and perform a trial run of the upgrade. All customers are entitled to a test license for this purpose.
  3. Read the release notes and upgrade guides for all releases between your version and the latest version.
  4. Check the table below to see which installer type is required.

Which installer should I use?

With certain upgrade paths, a full installation of Cascade CMS is required in order to ensure that the application has the latest required libraries. See the table below for a summary of which installer you should use based on the version from which you are upgrading. For any versions that do not require a full installation, using the ROOT.war upgrade method is allowed.

Upgrade Path
Upgrading From Full Installation Required
7.x Yes
8.0.x Yes
8.1.x Yes
8.2.x Yes
8.3 Yes
8.4.x Yes
8.5 Yes
8.6.x Yes
8.7.x Yes
8.8.x Yes
8.9 Yes
8.9.1 Yes
8.10 Yes
8.11.x Yes
8.12 Yes
8.13 Yes